OpenOffice/Draw – rajzoló

A Wikikönyvekből, a szabad elektronikus könyvtárból.
Ugrás a navigációhoz Ugrás a kereséshez


OpenOffice/Draw – rajzoló

A fejezet végére képes lesz:

  • Egyszerűbb rajzokat készíteni,
  • elemi rajzobjektumokat formázni,
  • menteni és exportálni,
  • grafikai objektumokat módosítani.

Figyelem! Ez a fejezet jelenlegi formájában az OpenOffice.org 1.x változatához készült. A Draw a 2.x verziójú változatban sokat változott és több új funkcióval bővült. Ezért az újabb verzióhoz ez a leírás csak közelítéssel, mintegy támpontként használható, például várhatóan bizonyos funkciók máshol elérhetőek. Kérlek, ha különbségeket találtál, bátran javítsd ki a leírást!

Az Draw használatának megkezdése[szerkesztés]

A Draw nevű program az OpenOffice.org vektoros rajzolóprogramja, meglehetősen gazdag eszközkészletet biztosít egyszerűbb és bonyolultabb rajzok elkészítéséhez.

Elindítása után az alábbi kép tárul elénk:

Üres rajzdokumentum

A menüsor alatt helyezkedik el a Műveletek eszköztár, ami teljesen megegyezik a Writerben megszokottal. Alatta található az Objektum eszköztár, ez már a Draw sajátja.

Az objektum eszköztár

Az ikonok jelentése balról jobbra:

  • Végpont: Bezier csomópontok szabadkézi szerkesztése,
  • Vonal: vonalrajzolás,
  • Nyíl stílusa: vonalak végén elhelyezkedő nyilak formája,
  • Vonalstílus: milyen legyen a vonal,
  • Vonalvastagság: milyen vastag legyen a vonal,
  • Vonal színe: milyen színű legyen a vonal,
  • Terület: kitöltőszínt adhatunk egy zárt alakzathoz,
  • Terület stílusa és kitöltése: milyen legyen a terület kitöltőszíne,
  • Árnyék: az árnyék beállítása.

A Fő eszköztár a képernyő bal oldalán helyezkedik el:

A fő eszköztár
  • Kiválasztás: több rajzelem esetén ezzel választhatjuk ki az alakítani valót.
  • Nagyítás: a megjelenő kis panelen a képernyőn való nagyítást állíthatjuk be.

Nagyítási opciók

  • Szöveg: szöveget vihetünk be.
  • Téglalap: különböző négyszögeket rajzolhatunk vele.
  • Ellipszis: ellipszist lehet vele rajzolni.
  • Térbeli objektumok: térhatású elemek rajzolásához. Ha ezeken az egér bal gombját lenyomva tartjuk, akkor egy kis úszómenü jelenik meg mindegyiknél, ahol pontosíthatjuk, hogy mit is szeretnénk rajzolni.
  • Görbék: görberajzoláshoz.
  • Vonalak és nyilak: vonalak rajzolásához, illetve nyilak készítéséhez.
  • Összekötő: két objektumot automatikusan összeköt, folyamtábra-készítéshez kitűnő.
  • Hatások: forgatás, tükrözés stb.
  • Igazítás: objektumokat igazíthatunk egymáshoz képest, illetve a laphoz képest.
  • Elrendezés: több egymáson lévő objektum sorrendjének a megváltoztatása.
  • Beszúrás: diagramot lehet beszúrni.
  • Térhatás: az elemek térhatási beállításait lehet itt módosítani.

A negyedik eszköztár a Beállítások eszköztár alapesetben nem látszik a képernyőn. Bekapcsolni a Nézet menü Eszköztárak pontjában lehet, vagy egy eszköztáron való jobb egérgombos kattintással a helyi menüből.

A Beállítások eszköztár

A Draw alapértelmezett állománykiterjesztése az SXD. Ebbe a formátumba menti az állományokat. A Fájl menü Exportálás parancsával azonban nagyon sok fajta külső formátumba lehet az állományunkat exportálni.

Exportálható fájltípusok

Egy objektumot a legegyszerűbben a helyi menüből lehet formázni. Kattintsunk a kiválasztott objektumon az egér jobb gombjával és választhatunk igényünk szerint.

A Draw kontextus-menüje

A Vonal és a Terület pontokban színezhetjük az objektum körvonalát és kitöltését. A Pozíció és méret pontban megadható a pontos mérete és elhelyezkedése a lapon, valamint az elforgatás szöge. Itt lehet egy szögletes objektum sarkait lekerekíteni is.

A Pontok szerkesztése menüben a görbévé alakított objektum töréspontjait és segédpontjait lehet mozgatni.

A Karakter és a Bekezdés pontok szövegekre értelmezhetők, ezek tulajdonságainak beállítására szolgálnak.

Az elrendezés pontban lehet egymásra helyezni az objektumokat.

Az Igazítás pontban lehet egymáshoz képes igazítani az objektumokat. Például itt lehet egy vonalba állítani őket.

A Tükrözés pontban az objektumot lehet vízszintesen és függőlegesen tükrözni.


Az Átalakítás pont a legérdekesebb.

A kontextus-menü Átalakítás pontja további menübe vezet

Itt lehet a Görbévé ponttal egy objektumot Bezier objektummá alakítani. A Sokszöggé alakítással sok-sok töréspont keletkezik és ezeket egyenesek fogják összekötni, így alakul ki az objektum. A Körvonallá választásával az objektumnak csak körvonala lesz.

A Térbelivé a síkidomból egy ál térbeli objektumot készít, amit a Fő eszköztár utolsó, Térhatás pontjával formázhatunk.

Különböző alapbeállítások a térhatásokhoz

A Geometria fülön határozhatjuk meg, hogy hogyan keletkezzen a térbeli objektum.

A térbeli test szerkezetének beállításai

Az Árnyalás fülön az árnyékolás minőségét állíthajuk be, és bekapcsolhatjuk a vetett árnyékot. Itt nyílik mód annak beállítására is, hogy honnan nézzük a térbeli testet.

Az Árnyalás, az Árnyék és a Kamera beállítása

Az Anyag fülön beállíthatjuk a térbeli test anyagának minőségeit.

A test felszínének és csillogásának beállításai

Példaképpen két eredeti objektum, mellette jobbra a Térbelivé alakított másuk alapbeállításokkal:

Körből és négyzetből keletkezett térbeli képek

Ha Térbeli forgástestté alakítjuk az objektumot, akkor az alábbi formákat kapjuk:

Körből és négyzetből keletkezett forgástestek

Néhány különlegesség[szerkesztés]

„Olló és ragasztó...”[szerkesztés]

Lehetőségünk van több alakzattal matematikai műveleteket is végezni. Ne ijedjen meg senki, nem kell számolni, hanem a program több alakzat kijelölése esetén, ha ezek fedésben vannak (legalább részben), akkor képes összeadni őket, kivonni őket egymásból, illetve metszetet készíteni belőlük. A felső képen az eredeti objektumok, alattuk az előbb említett műveleteket elvégezve rajtuk. Ezt a Módosítás menü Alakzatok pontjában lehet elérni.

Az az objektum körvonal és kitöltés szempontjából a döntő, amelyik legalul van.

Négyzet és kör összeadva, kivonva, és a metszetük

Betűbűvész[szerkesztés]

Nem vicc, a Formátum menü utolsó előtti pontja ez. Ha rákattintunk, akkor megjelenik egy úszó ablak. Ennek a segítségével lehet egy szöveget tetszőleges ívre görbén ráilleszteni különböző módon, gyakorlatilag két-három egérkattintással.

Itt lehet körbeírni, pecsétszerű írást alkalmazni, illetve tetszőlegesen dönteni az íven a betűket.

A kiválasztott görbe természetesen szerkeszthető a Körvonal nyomógomb segítségével.

A Betübűvész beállításai

Úszó keret[szerkesztés]

Ez a menüpont a Beszúrás menüben található.

Úszó keret tulajdonságai

A Tartalom részbe egy internetes webcímet beírva annak tartalma egy keretbe letöltődik és megjelenik a rajzterületen. Így ágyazhatunk be weboldalakat közvetlenül az internetről.

Gyakorló feladatok[szerkesztés]

Jó lenne ilyen is...