OpenOffice/Calc – táblázatkezelő

A Wikikönyvekből, a szabad elektronikus könyvtárból.
Ugrás a navigációhoz Ugrás a kereséshez


OpenOffice/Calc – táblázatkezelő

A fejezet végére képes lesz:

  • Kezelni egy grafikus táblázatkezelő programot,
  • alapvető fájlműveleteket végezni vele,
  • táblázatokat formázni,
  • diagramot készíteni,
  • egyszerűbb függvényeket és képleteket alkalmazni.


Az Calc használatának megkezdése[szerkesztés]

Windows-on például a Start menü Programok csoportjában lévő OpenOffice.org csoportban a Munkafüzet pontra kattintva indíthatjuk, illetve ha használjuk a Gyorsindítót, akkor a tálcán a jobb egérgombbal az ikonra kattintva a Munkafüzet pontot kiválasztva, a táblázatkezelőt.


Az ablak részei[szerkesztés]

Menüsor: a címsor alatt található, ebből választhatjuk ki az adott elvégzendő szerkesztési feladatot. Ez a „bázis”, hiszen az egyes menükben minden lehetséges funkció megtalálható, elérhető a megfelelő csoportosításban.

Eszköztárak: Általában a menüsor alatt és a bal oldalon találhatjuk az eszköztárak közül a láthatóakat, de nem minden esetben és nem mindig ugyanazokat. Minden fontos feladatcsoportnak saját eszköztára van, ezek közül egyidejűleg többet is láthatóvá tehetünk. Az eszköztárak eszközgombokat tartalmaznak, ezek segítségével a leggyakrabban használatos parancsok közvetlenül a munkafelület mellől, kézre állóan elérhetők, nem kell a menükben több lépésben keresgetnünk. Az eszköztárak, ha nincs rá szükségünk, kikapcsolhatók. Erre szolgál a „Nézet” legördülő menü „Eszköztárak” almenüje. Ha kattintunk egy adott eszköztár neve mellett, úgy az vagy láthatóvá válik vagy éppen ellenkezőleg, kikapcsoljuk. Ami mellett pipa jelet látunk, az látható. Az eszköztárak eszközgombjai tetszőleges sorrendben jeleníthetők meg. Minden eszköztárat egyéni ízlésünknek megfelelően alakíthatunk az „Eszközök” menü „Testreszabás” funkció választásával. Lehetőségünk van egyénileg összeválogatni új eszköztárat is.

Képlet eszköztár: A képlet eszköztár szolgál az egyes cellák tartalmának a megjelenítésre. A képlet eszköztár a mutató funkción túl arra is alkalmas, hogy a beíró kurzorunkat a beíró sávba mozgatva módosíthassunk a cella megjelenő tartalmán, ha szükséges.

Görgetősávok: A görgetősávok arra szolgálnak, hogy a táblázatunkat a vízszintes és függőleges irányba mozgatni tudjuk, hiszen a képernyőn a táblázat egészének általában csak egy részletét láthatjuk.

Munkalap: Ez tulajdonképpen az a táblázat, amiben dolgozunk, oszlopokba és sorokba rendezett cellákból áll.

Lapfülek: Egy ablakban általában egy munkafüzet van nyitva, ami munkalapoknak nevezett táblázatokból áll. Ezek közt lehet váltogatni a lapfülek eszközzel. Az aktív munkalap lapfüle áttetsző, a többi a programablak háttérszínéhez hasonló.

Állapotsor: A képernyő alján találjuk. Ebben hasznos információkat olvashatunk a táblázatunkról, illetve a munka menetéről. OOo1 Calc Üres dokumentum.png

A táblázatok építőelemei[szerkesztés]

A cellák sorokból és oszlopokból állnak. A sor és oszlopvonalak által határolt építőelemeket celláknak nevezzük, ezek a táblázatok alapelemei. A táblázat sorait számokkal jelöljük –sorjelölők-, míg az oszlopokat betűkkel –oszlopjelölők. Mivel a oszlopjelölő betűk száma egyesével csak 26 oszlop jelölésére lenne elég, ezért a Z oszlop után kettős betűvel AA, AB, AC… folytatódik az oszlopazonosítás, és tart egészen IV-ig.

Munkafüzet, Munkalap[szerkesztés]

Ahogy az előzőekben említettük, a Calc elindítása után úgynevezett Munkafüzetet nyit meg számunkra. Mindig egy-egy munkafüzettel dolgozunk, viszont maga a táblázat nem a munkafüzet, hanem a munkafüzetben lévő egy-egy munkalap. A munkafüzet nem csak egy táblázatot, hanem alapértelmezésben hármat, (Munkalap1, Munkalap2, Munkalap3) egyébként tetszőleges számút tartalmazhat. Ezek számát mindig a feladatnak megfelelően választhatjuk meg a munkafüzetünkben. A munkafüzet egy-egy táblázatát Munkalapnak nevezzük. Van olyan munkafüzet, amely csak egy, és van olyan, amely több munkalapot (táblázatot) tartalmaz.

A munkafüzetünkben az éppen használt, aktív munkalapunk az ablak alsó, lapfülek részén áttetszően látszik.

Az éppen használt, aktív táblázatunknak (munkalapunknak) mindig van egy kitüntetett cellája, amelyben éppen dolgozhatunk, például adatot vihetünk be. Ezt a cellát aktív cellának nevezzük, és értelemszerűen azért lehet belőle csak egy, mivel egyszerre nem lehet több helyre adatot bevinni.

Az aktív cellát látható keret jelöli, ami a cella értékét mutatja, a képlet eszköztár mindig az aktív cella tartalmát mutatja, míg az úgynevezett Névdobozban az aktív cella azonosítója, hivatkozása látható.

Mozgás a táblázatban[szerkesztés]

Belegondolni is nehéz, milyen nagy felületű üres táblázaton dolgozhatunk a Calc munkalapjain. Erre viszont, ha nem is mindig, de sok adat esetén szükségünk is lesz. Képzeljük el úgy, mint egy óriási nagy „kockás papírt”, amelyre valamely szegletéből indulva adatokat írhatunk. Teljesen tetszőleges, hogy az adatainkat a táblázat mely cellájából indítva rögzítjük. A fontos az, hogy tudjuk az adatcellák helyét, hogy hol találjuk meg adatainkat.

Induláskor az aktív cella az A1-es, ami azt jelöli, hogy az A oszlop 1 sorában lévő cellában vagyunk. Általában, mint ahogy papíron is, a bal felső sarokból szoktunk kiindulni. Érdemes ezt a gyakorlatot követni a táblázatkezelőben is.

Az aktív cella legegyszerűbb kiválasztása az egér segítségével történhet, egyet kattintanunk kell a kívánt pozíción. Előfordulhat, hogy az aktív cella éppen nem látható a képernyőn, látszólag nincs keretes cellánk. Természetesen ilyenkor is van aktív cella, csak a képernyőnkön a táblázat olyan részletét látjuk, amely nem tartalmazza a kijelölt cellát. Figyeljük meg ilyenkor a Névdobozban az aktív cella hivatkozását, és használva a gördítő sávokat, mozogjunk a táblázatunkban megfelelő irányban úgy, hogy az aktív cella a képernyőn látható legyen.

A táblázatunkon belül nem csak az egér és a gördítő sávok segítségével, hanem a billentyűzetünk kurzormozgató nyilaival is mozoghatunk (, , , ). A CTRL+ billentyűkombinációkkal a táblázatunk aktív celláját tartalmazó sorának legutolsó oszlopára (C5 cellán állva így az IV5 cellára ugordhatunk), CTRL+ billentyűkombinációval a legelső oszlopára ugrunk. A CTRL+ billentyűkombinációkkal a táblázatunk aktív celláját tartalmazó oszlopának legutolsó sorára (C5 cellán állva így az C65536 cellára ugordhatunk), CTRL+ billentyűkombinációval a legelső sorára ugrunk.

Egy adott cellához ugrásra gyors megoldás az, hogy a Névdobozba visszük a beíró kurzort (kattintunk a Névdobozba), majd begépeljük a kívánt cella hivatkozását. (például: E10; BC20; stb.) Az ENTER billentyű leütésére az aktív cella a Névdobozba beírt hivatkozású lesz, és magát a cellát a képernyőnkön is látni fogjuk.


Adatok bevitele[szerkesztés]

Az adatok beviteléhez első lépésként ki kell jelölnünk aktív cellának azt, amelybe az adatot rögzíteni szeretnénk. Miután ez megtörtént, egyszerűen elkezdhetünk gépelni. Amit beírunk, az megjelenik mind az aktív cellában, mind a képlet eszköztárban. Az adatbevitel végét többféleképpen jelezhetjük. Lenyomhatjuk az ENTER, vagy a TAB vagy valamelyik kurzormozgató billentyűt, kattinthatunk egyet egy másik cellán.

A táblázatunkba, számokat, dátumot, időpontokat és szövegeket vihetünk be bizonyos beviteli szabályok betartásával.

Számok: Arra kell figyelnünk, hogy bármely számérték bevitelénél ne használjunk semmilyen, a szám mellé vagy közé kerülő objektumot. Nem kell használnunk szóközt sem! A Calc csak ennek a szabálynak a betartása mellett tudja a cellába beírt számértéket különböző számításokhoz felhasználni. Természetesen jogos igény az, hogy a számértékek mellett egyes esetekben például mértékegységek, vagy egyéb kiegészítő szövegobjektumok jelenjenek meg. Ezt azonban soha nem az adatbevitellel, hanem az adott cella megjelenítési beállításainál alakítjuk ki. (Lásd később: Cellaformázás). Törtszámok beírásánál azt a tizedes-elválasztó jelet kell használnunk, amit alapértelmezettként a számítógép Területi beállításainál meghatároztunk. A Calc mindig ehhez igazodik. A szokásos beállítás a tizedesvessző, általában ezt használjuk. Helyes például a „456,25”. A Calc a számként érzékelt cellák tartalmát mindig jobbra igazítja mindaddig, míg az igazítást nem változtatjuk mássá.

Dátumok: Dátumértékek bevitelénél megint csak azt a dátum-elválasztó karaktert kell az évszámok, hónapok, napok között beütnünk, amit az operációs rendszer Területi beállításainál megadtunk. Magyarországon ez általában a pont. A beállítástól függetlenül a Calc felismeri és elfogadja a / és a – jeleket is. Kezdjük mindig az évszámokkal, majd a dátum-elválasztó karakter megadása után a hónapokkal, majd ismét dátum-elválasztó után a napokkal. (Például „2003.4.30 vagy 2002/1/15). A dátumérték végére nem kell feltétlenül dátum-elválasztó karakter, de ha teszünk, az sem jelent problémát. Az évszámok megadásánál elegendő az évszázadok nélkül, csak az utolsó két karakter megadása. Ha az éveket a dátum megadásánál elhagyjuk, úgy az aktuális dátum évszámával kerül a dátum a cellába. Azaz, ha 2003-ban beütjük a 4.3 dátumot, úgy az 2003.04.03-ként kerül tárolásra, a képernyőn azonban csak a 4.3 jelenik meg. A számokhoz hasonlóan a dátumok is jobbra igazítottak jóváhagyás után. Ezt a tulajdonságot adatbevitel után rögtön használhatjuk annak ellenőrzésére, hogy helyesen vittük-e be az adatot.

Időpontok: A számítógép területi beállításainál az általában alkalmazott időelválasztó a kettőspont. Gépeléskor az óra után írjuk a kettőspontot, majd a perceket. Ha szükséges, kettőspont után megadhatjuk a másodperceket is. Például 17:25:56. Az időpontok az előzőekhez hasonlóan szintén jobbra igazítottak.

Szövegek: Ez az adatforma, aminek a bevitelénél nincs szabály, amire ügyelnünk kellene. Bármi más, ami nem tartozik a szám, dátum, idő kategóriák valamelyikébe, szövegként kerül tárolásra. A szövegként tárolt cellákkal nem végezhetünk számításokat! A szöveg jellegű cellák balra igazítottak. Ha egy adott cellán belül szeretnénk új sorba gépelni, úgy azt a CTRL+ENTER billentyűkombinációval érhetjük el.

Adatmódosítás, törlés[szerkesztés]

Sok esetben van szükségünk arra, hogy az egyes cellák tartalmát módosítsuk. Természetesen teljesen átírhatunk tartalmat, de javíthatunk vagy törölhetünk is.

Átírás: Ha az átírást választjuk, nem kell mást tennünk, mint beírásnál. Az adott cella kijelölése után már gépelhetjük is az új tartalmat, az adatbevitel jóváhagyása után a régi cellatartalom elvész és átveszi helyét az új. Ha elkezdtük az átírást, de még jóváhagyás előtt észrevesszük, hogy nem jót cselekszünk, úgy az ESCAPE (ESC) billentyű lenyomásával érvényteleníthetjük a műveletet.

Javítás: Ha egy adott cellában az adattartalom részben jó, és csak módosításra van szükség, akkor a cellára való dupla kattintással, vagy kijelölés után egy kattintással a képlet eszköztáron, esetleg kijelölés után az F2 funkcióbillentyű lenyomásával elérhetjük azt, hogy az adott cellába kerül a beíró kurzor, és ott lehetőségünk van mozgásra, karaktertörlésre, javításra.

Törlés: ha egy adat feleslegessé válik, akkor a cella kijelölése után nem kell mást tennünk, mint használnunk a DELETE billentyűt. Ekkor maga a cella nem, csak a benne tárolt tartalom törlődik, kivéve az esetleges szegély beállításokat. (Lásd később: Cellaformázás)

Kijelölések a táblázatban[szerkesztés]

Tartomány kijelölése[szerkesztés]

Tartománynak nevezzük a táblázatunkban azokat az egymással szomszédos cellákat, amelyeket egyidejűleg jelölünk ki. Értelemszerűen az egymással szomszédos cellák kijelölve mindig téglalap formájú területet alkotnak.

Egy adott tartomány kijelölése akképpen történik, hogy:

  1. az egerünk kiválasztásra beállított (általában bal oldali) gombjával kattintunk a kijelölni kívánt tartomány egyik sarkában lévő cellán, és nyomva tartjuk az egérgombot, majd
  2. a nyomva tartott egérgomb mellett, a kijelölni kívánt téglalap területű tartomány - átlósan elhelyezkedő – szemközti cellájába mozgatjuk az egerünket.
  3. Ha odaértünk, elengedhetjük az egérgombot.

Kijelölés közben az oszlop és sorjelölőket kell figyelnünk ahhoz, hogy ne tévedjünk el a kijelöléssel. Ne feledjük, amíg elindulás után nem engedjük el az egérgombot, addig nem fejeződik be a kijelölés, vagyis vissza is mozoghatunk, ha esetleg túlhúznánk a kívánt területet. Ha mégis elrontanánk a kijelölést, nem kell mást tennünk, minthogy az elejétől kezdve megismételjük a műveletet. Kijelölés közben a Névdoboz nem egy cella hivatkozását, hanem azt mutatja, hogy melyik cellától melyik celláig terjed a kijelölés.

OOo1 Calc Cellák kijelölése.png

Ha az egérkezeléssel nehézségeink lennének, úgy választhatjuk azt a módszert is, hogy a tartomány egyik cellájából indulva lenyomjuk, és nyomva tartjuk a SHIFT billentyűt, majd kattintunk a tartomány másik sarkában lévő cellán, végül elengedjük a SHIFT gombot.

A tartományoknak is van hivatkozásuk, vagy más néven azonosításuk. Téglalap alakú tartományra úgy hivatkozhatunk, hogy a téglalap két – átlósan - szemközti cellájának a hivatkozását kettősponttal elválasztva egymástól leírjuk.

Sorok és oszlopok kijelölése[szerkesztés]

Egy teljes sort vagy oszlopot úgy kell kijelölnünk, hogy az adott sor vagy oszlop elején illetve tetején található sor illetve oszlopjelölő, szürke színű számon vagy betűn kattintunk egyet.

Több sor vagy oszlop együttes kijelölése ugyanúgy történik, mint a tartományoknál. Például, ha ki akarjuk jelölni a 2-es sortól a 10-es sorig az összest, akkor a 2-es sor szürke színű, 2-es számú sorjelölőjére kell állnunk, majd lenyomott egérgomb mellett le kell húznunk egerünket egészen a 10-es sorjelölőig, majd ott elengednünk az egérgombot. Oszlopok esetében ugyanez a feladat, csak ott a kívánt oszlopjelölőtől indulva végezzük a kijelölést a befejező oszlopjelölőig.

???Természetesen ezeknek a kijelölt területeknek is van hivatkozásuk. Ez úgy alakul ki, hogy megadjuk az első sor (vagy oszlop) jelét, ezután kettőspontot teszünk, végül az utolsó sor (vagy oszlop) jele következik. Tehát például a 2-estől a 10-ig terjedő sorokat a 2:11 hivatkozással adhatjuk meg. Ha csak egyetlen sort vagy oszlopot jelöltünk ki, akkor ugyanaz lesz az első és az utolsó sor (vagy oszlop). Tehát például a 10:10 a 10-es sorra való hivatkozást jelenti, Míg a C:C a C oszlop hivatkozása.??? - (Ez a 2.1-nél nem működik!)

A teljes táblázat kijelölése[szerkesztés]

A teljes táblázatunk, vagyis a munkalap összes cellájának egyidejű kijelölésére is van lehetőségünk. Erre legtöbbször akkor van szükségünk, amikor egy munkalapon lévő táblázat nagyon nagy, nehézkes lenne a kijelölése a már ismert módszerekkel. Másik jellemző eset az, amikor úgynevezett vágólap segítségével szeretnénk egy adott táblázatot egy másik munkalapra átmásolni, és nem szeretnénk, hogy esetleg nem látható részen lévő adataink lemaradjanak. A táblázat egészének kijelölésére az oszlop és sorjelölők találkozásánál, az A1-es cella közelében kell kattintanunk az üres szürke téglalapon. Ha kattintunk, a teljes táblázat kijelöltté válik.

Nem összefüggő terület kijelölése[szerkesztés]

Gyakran van arra is szükségünk, hogy egyszerre több, különböző területet jelöljünk ki. Azt tapasztaljuk, hogy ha egy kijelölésünk már van, és újabbat akarunk kijelölni, akkor az első kijelölésünk megszűnik.

A probléma áthidalására a megoldás az, hogy az első kijelölés után lenyomjuk a CTRL billentyűt, és mindaddig lenyomva tartjuk, amíg az egerünkkel kijelöljük az újabb területet, vagy területeket. Több kijelölés is lehet egyszerre a táblázatunkban, és azok alakja egymástól teljesen eltérő is lehet (sor, oszlop, tartomány, cella).

Ha többes kijelölést végeztünk, és meg kell adnunk a kijelölések hivatkozását, akkor a megoldás az, hogy vesszővel, vagy pontosvesszővel elválasztva fel kell sorolnunk az egyes területek hivatkozását egymás után.

Cella, sor, oszlop, tartomány törlése, beszúrása[szerkesztés]

A cella beszúrása azt jelenti, hogy a táblázatban egy új cella jelenik meg, az eredeti cella eltolódik az általunk kiválasztott irányba. Kiválaszthatjuk, hogy az eltolódás jobbra, vagy lefelé történjen. (Természetesen egy új cella beszúrása nem azt jelenti, hogy a munkalapunk rögzített cellaszáma (65536 sor és 256 oszlop szám szorzata) ilyen esetben nő. Csak annyi történik, hogy az adott pozícióban lévő cella helyére egy üres új cella előrelép a táblázat széléről, vagy végéről.)

Gyakorlatban cellát úgy szúrhatunk be, hogy kijelöljük azt a cellát, aminek a helyére egy újat szeretnénk tenni, majd jobb egérgombbal kattintva az adott cellán a megjelenő gyorsmenüből a Cellák beszúrása... menüpontot választjuk. Ugyanezt érhetjük el a Menüsor „Beszúrás” menüjéből a „Cellák...” menüpont választásával.

OOo1 Calc Cella beszúrása.png

A beszúrásnál megjelenő panelben megjelenik az egész sor, vagy egész oszlop beszúrásának választási lehetősége is. Ez azért logikus, hiszen egy adott cella egy oszlopnak és egyben egy adott sornak is eleme, tehát a Calc tudja azonosítani az adott sort vagy oszlopot is. Sorok és oszlopok beszúrására talán kézenfekvőbb megoldás, hogy az oszlop és sorjelölőkkel elöször kijelölünk egy sort, majd utána választjuk a Sorok beszúrását. A gyorsmenüből indulva automatikusan beszúródik a kijelölt sor vagy oszlop elé egy új.

A táblázatok formázása[szerkesztés]

Sormagasság és oszlopszélesség állítása[szerkesztés]

Ahhoz, hogy a táblázatunk adatbevitel után megfelelő képet mutasson, az egyik legfontosabb lépés a cellák méretének a beállítása. Ez azért fontos, hogy a cellákban a bennük lévő adatok „elférjenek”, azaz láthatóak legyenek teljes terjedelmükben. Természetesen a cellában lévő adat mindig elfér a cellában, hiszen az nem egy korlátos, szűk ketrec. Itt arra gondolunk, hogy megjelenés szempontjából lehessen látni a teljes tartalmat, vízszintesen és függőleges irányban is. Ehhez be kell állítanunk az oszlopok szélességét, illetve a sorok magasságát.

Ha két oszlopjelölő szürke téglalap közé visszük az egérmutatót, akkor az egérkurzor alakja kettős nyíl alakot vesz fel. Ez jelzi számunkra azt, hogy ebben a pillanatban megváltoztathatjuk az oszlopok szélességét. Ilyen kurzorállapot mellett le kell nyomnunk az egérgombot, és lenyomva tartott gombbal mozgatni az egeret. Látszani fog, hogy az adott oszlop szélessége változni fog a mozgatás irányának megfelelően. Hasonlóan állítható a sorok magassága is. Az adott sor után állva a kettős nyíl megjelenése után lenyomva tartott egérgombbal, az egér mozgatásával állíthatjuk be a kívánt sormagasságot.

Ha egyszerre több oszlopnak vagy sornak egyidejűleg szeretnénk azonos szélességet vagy magasságot állítani, úgy a feladat ugyanaz. Ki kell jelölnünk egyidejűleg az azonos méretűvé formázni kívánt oszlopokat vagy sorokat, majd a kijelölt rész oszlop vagy sorjelölői közül bármelyikhez állva a kettős nyíl megjelenése után már állíthatjuk is a kívánt méretet. Ebben az esetben az össze kijelölt objektum azonos méretűvé alakul.

Egy másik hasznos lehetőség az, hogy ha a kettős nyíl megjelenésekor kettőt kattintunk. Ekkor az oszlop szélessége vagy a sor magassága automatikusan olyanná lesz, hogy a cellákban lévő adatok közül a leghosszabb is elférjen.

Objektumok elrejtése és felfedése[szerkesztés]

Sokszor szükségünk van arra, hogy a már elkészült táblázat bizonyos részeit eltüntessük a képernyőről és a nyomtatásból is. Véglegesen nem akarjuk törölni az objektumokat, hiszen akkor a bennük foglalt adatok is törlődnek, és ez azzal járhat, hogy a táblázatunk egyes számítási képletei nem működnek helyesen. Mégis azt szeretnénk, hogy mi magunk vagy mások ne lássanak egyes részleteket. (Például egy kereskedő cég vevő partnereinek nem mutatja meg a termékek beszerzési árait, hanem csak az eladási árakat.)

Ha a két adat egy táblázatban van, akkor ilyen esetben el kell, hogy rejtse a beszerzési árakat tartalmazó cellákat. A gyakorlatban ez úgy történik, hogy az adott sorok vagy oszlopok méretét nullára csökkentjük. A kiválasztott oszlopjelölő jobb szélére állva az egérrel, a kettős nyíl megjelenése után nyomva tartott egérgomb mellett balra húzzuk az egeret az oszlop elejéig. Ha ilyen műveletet végzünk, akkor az oszlopjelölők közötti folyamatosság megváltozik, például A után C vagy valami más következik a B helyett.

Elrejtett oszlopok felfedésére két lehetőségünk van. Az egyik, hogy az elrejtett oszlopok helyén az oszlopjelölőn az oszlop elejére állunk, és finoman jobbra mozgatjuk az egeret lenyomott egérgomb mellett. A másik lehetőség az, hogy kijelöljük az elrejtett oszlopokat a velük szomszédosokkal együtt, és az oszlop vagy sorjelölőn jobb egérgombbal előhívott Gyorsmenüből kiválasztjuk a Megjelenítés parancsot.

Cellák formázása[szerkesztés]

A legegyszerűbben úgy formázhatjuk meg a cellát vagy cellákat, hogy kijelöljük, a jobb egérgombbal kattintunk és a helyi menüből a Cellák formázása... pontot választjuk.

OOo1 Calc Cellák formázása Számok.png

A különböző füleken állíthatóak be az egyes tulajdonságcsoportok jellemzői. Az első fül a „Számok” fül. Itt a cellában szereplő adat típusát határozhatjuk meg. Ha kiválasztottuk a Kategória részben a kívánt típust, akkor a Formátum részben a neki megfelelő formátumok közül választhatunk. Ha a már meglévő kategóriákban nem találunk nekünk megfelelőt, akkor a korábbiak módosításával az Egyéni kategóriába definiálhatunk tetszőleges típust.

A következő kategóriák vannak:

  • Szám: itt állíthatjuk be a megjelenítendő tizedes-jegyek számát, akarjuk-e a számokat ezres tagolásban – szóköz beszúrásával - csoportosítva látni, illetve, hogy a negatív számok előjellel, vagy piros színnel legyenek-e megkülönböztetve.
  • Pénznem: a számok után a Ft vagy általunk beállított más devizanem jelenjen meg. Itt is van lehetőség a tizedes-jegyek és a negatív számok megkülönböztetett megjelenítésének beállítására.
  • Dátum, idő: mindkét kategóriánál többféle megjelenítési lehetőség közül választhatunk egy adott felsorolásból. Figyeljük a minta mezőt!
  • Százalék: ez a megjelenítési forma egy százalékjelet ír ki a szám után, és megszorozza a számot százzal. Erre oda kell figyeljünk már a szám beírásakor is, ha tudjuk, hogy százalékos formában akarjuk megjeleníteni. Ha azt szeretnénk, hogy 75 % jelenjen meg a képernyőn, akkor 0,75-öt kell begépelnünk! Ennél a kategóriánál is van tizedes jegy beállítási lehetőségünk.
  • Egyéni: a formátumkódok segítségével egyéni számforma beállításokat alakíthatunk ki. A Minta mezőben láthatjuk, hogy az alatta kiválasztott formátumkód milyen beállítást eredményez.

A leggyakoribb formátumkód karakterek:

  • #: egy számjegyet szimbolizál
  • 0: egy számjegyet szimbolizál. Ha a szám kevesebb számjegyet tartalmaz, akkor nulla jelenik meg helyette
  • vessző: meghatározza a tizedesvessző elhelyezkedését, illetve azt, hogy hány számjegy jelenjen meg a tizedesvessző jobb és bal oldalán
  • szóköz: ezres elválasztóként használható
  • ” ” aposztróf jelek. Ami a két jel közé kerül, az szövegként jelenik meg (például: ”szöveg”).

A legtöbbször arra van szükségünk, hogy valamilyen mértékegységet tehessünk a számok után. (például: l, darab, hektár, stb.) Bármilyen szöveget megadhatunk, ha a formátumkódhoz a 0”szöveg” kódot használjuk, ahol a szöveg szó helyére kell a kívánt szöveget megadnunk. Ha a megjelenítésben szóközre van szükség, úgy azt az idézőjelen belül kell megadnunk!

A következő fül a „Betűkészlet”. Itt a kijelölt cella vagy cellák tartalmának betűtípusát, stílusát, méretét állíthatjuk be.

A „Betűhatások" fülön belül az aláhúzást, áthúzást, a betűszínt és néhány speciális hatást rendelhetünk a karaktereinkhez.

Az „Igazítás” fülön a cellában szereplő adatok elhelyezkedését szabályozhatjuk. Igazíthatjuk külön vízszintesen és külön függőlegesen a cellán belül elhelyezkedő adatokat, valamint baloldali behúzást is rendelhetünk hozzá. A Szövegirány részben a cellákban lévő szöveg vagy szám elforgatását szabályozhatjuk.

OOo1 Calc Cellák formázása Igazítás.png

A Fok mezőbe tetszőleges értéket írhatunk 0 és 360 között, ennyivel lesz elforgatva a szöveg. Ha a kis fekete rombuszt megfogjuk a körön, akkor szabad kézzel is forgathatunk. Megadhatjuk mellette, hogy a cellán belül legyen, vagy alul vagy felül legyen az alapél. Az Automatikus sortörést bekapcsolva a program – ha szükséges – több sorba rendezi a cellában lévő adatot.

A következő fül a „Szegélyek”. A táblázat látványosabb megjelenítéséhez szoktuk szegéllyel ellátni a cellákat. A szegély gyakorlatilag nem más, mint az adott cella oldalhatároló vonalain a nyomtatásban, és természetesen a képernyőn is megjelenő vonal, aminek van stílusa, színe, vastagsága. Ne tévesszen meg bennünket az, hogy a programban mindig látunk a cellák körül vonalakat. Ezek a szürkés vonalak a segédrácsok, amik segítenek bennünket a táblázatban való eligazodásban. Ezek alapértelmezésben, a nyomtatásban nem jelennek meg, csak ha ezt külön beállítjuk. A Belső margók részben beállíthatjuk, hogy a szöveg milyen közel kerülhet a kerethez. Átlós szegélyek megadásával „kihúzhatunk” cellákat.

A Szegélyezés mindig a kijelölt objektumokra fog vonatkozni! Ne felejtsük el! A DELETE billentyű használata csak a cella tartalmát törli, a cella szegélyezését soha nem távolítja el!

Amennyiben több, különböző stílusú cellaszegélyt akarunk alkalmazni a táblázatunkban, akkor az azonosra formázni kívánt cellákat egymás után jelöljük ki, majd állítsuk be egymás után a kívánt szegélyeket!

OOo1 Calc Cellák formázása Szegélyek.png

A „Háttér” fülön a kijelölt cellák háttérszínét lehet megadni.

Az utolsó fül a „Cellavédelem”. Itt állíthatjuk be a cellák és képletek védelmét.

FONTOS: Csak akkor hat, ha a Munkalap védelme is be van kapcsolva! Ez az „Eszközök” menüben a „Dokumentum védelme” pontban kapcsolható be és ki. Ilyenkor egy jelszót rendelünk a dokumentumhoz. Ha a dokumentum védett, a védettnek beállított cellákat nem lehet módosítani, vagy egyáltalán meg sem jelennek. Az alapértelmezés, hogy a cellák védettek, így könnyen csinálhatunk olyan űrlapot, aminek csak néhány mezője módosítható (ahol kikapcsoljuk a védelmet), és az ott bevitt adatokkal bonyolultabb számításokat végez.

OOo1 Calc Cellák formázása Cellavédelem.png

Képletek[szerkesztés]

Képleteknek nevezzük azokat az utasítás és hivatkozás sorozatokat, melyek a táblázatkezelő nyelvén íródnak, így azokat képes a Calc értelmezni, és műveletenként végrehajtani. A képletek az alábbi elemekből állhatnak:

  • Konkrét értékek, számok, adatok (konstansok)
  • Hivatkozások egy-egy tartományra, az abban foglalt adatokra
  • Műveleti jelek (összeadás +, kivonás -, szorzás *, osztás /, hatványozás ^)
  • Függvények (adott feladat elvégzéséhez előre elkészített és használható utasítássorozatok, melyekhez az adatokat mi szolgáltatjuk)

A képleteket szintén a cellák tárolják.

Nagyon fontos szabály az, hogy a képletet mindig az egyenlőség jel = használatával indítsuk, mivel a Calc erről ismeri fel azt, hogy nem pusztán egy szöveg jellegű karaktersorozatot adtunk meg, hanem a képletben foglalt utasításokat végre kell hajtania és ki kell számítania az eredményt.

A képletek beírása ugyanúgy történik, mint bármely adaté. Egyszerűen ki kell jelölnünk a képlet helyének kiválasztott cellát, és máris kezdhetjük a beírást. Bár az egyes cellákra való hivatkozást mi magunk is begépelhetjük a képletbe, sokkal egyszerűbb és pontosabb, ha az egerünkkel rámutatunk az adott cellára és „kijelöljük” a képletbe építendő hivatkozást, így az automatikusan beíródik a képletünkbe.

Cella tartalma és cella értéke[szerkesztés]

!!! Innentől több hivatkozás is van valamilyen „elöbbi feladatra”, ami azonban hiányzik !!!

Képletek alkalmazásánál fontos észrevennünk azt az előző Feladatnál már érintett tulajdonságot, hogy egy képletet tartalmazó cellánál mást látunk a képlet eszköztáron, és mást magában a cellában. A cella tartalma alatt azt értjük, amit begépeltünk, vagy valamilyen más módszerrel a cellába vittünk. Ezt látjuk a képlet eszköztárban. A cella értéke az, amit magában a cellában látunk, vagyis a képlet által kiszámított eredményt.

Automatikus számolás tulajdonság[szerkesztés]

Mint azt az előbbi feladatnál megfigyelhettük, a táblázatkezelő egy-egy cella tartalmának módosulása esetén automatikusan újraszámítja azoknak a képleteknek az eredményét, amelyekben hivatkoztunk a módosuló cellára. Ez a táblázatkezelők egyik legnagyobb előnye! A képernyőn mindig az aktuális eredményt látjuk. Ha valamilyen okból kifolyólag nem szeretnénk élni az automatikus számolás lehetőséggel, úgy azt kikapcsolhatjuk az „Eszközök” menü „Cellatartalom” pontja alatt.

Függvények használata[szerkesztés]

A függvények az általunk megadott adatokból a függvény feladata szerint kiszámítanak és eredményül visszaadnak egy értéket (például összeget, átlagot számítanak, egy adott tartományban megkeresnek legkisebb vagy legnagyobb értékeket, megszámolnak előfordulásokat vagy logikai kapcsolatokat vizsgálnak).

A függvények a következőképpen néznek ki:

Függvénynév (paraméter1; paraméter2; paraméter3;….)

A függvény neve után a zárójelben meg kell adnunk egymástól pontosvesszővel elválasztva azokat az adatokat, amelyekből ki szeretnénk számolni valamit. Ezek az adatok lehetnek konkrét értékek (konstansok), hivatkozások, műveleti jelek, sőt akár újabb függvények is. Azért előnyös a függvények használata, mert bizonyos számításokat az alapvető műveleti jelek használata helyett függvények segítségével egyszerűbben elvégezhetünk. Ilyen például az összesítés, amit a cellák felsorolásával és a + műveleti jel alkalmazásával is végrehajthatnánk, ez azonban több száz cella esetén eléggé nehézkes lenne.

Az OpenOffice.org-ban a legegyszerűbben a „Beszúrás” menü „Függvénylista” pontja segítségével szúrhatunk be függvényt. Ekkor a jobb oldalon megjelenik egy ablak.

Egyszerűbb függvények[szerkesztés]

OOo1 Calc Függvénylista.png

A SUM függvény

Adatok összesítését nagyon egyszerűen elvégezhetjük anélkül, hogy az összeadás jel használatával egyesével felsorolnánk az összeadandó cellákat. Lehetőségünk van a függvénynél tartományok megadására is.

Az AVERAGE (ÁTLAG) függvény

Átlagolni annyit jelent, minthogy meghatározott adatértékeket összeadunk, majd az összeadás eredményét elosztjuk az összeadott adatértékek számával. !!! A mindjárt és később is többször említett színházas példa sehol sem található !!! Az alábbi példában azt számítottuk ki, hogy a budapesti színházakban átlagosan mennyi erkély, páholy, földszinti, stb. ülőhely van, illetve, hogy mennyi az átlag összes férőhely.

A MIN és a MAX függvény

Ha egy táblázat egy adott tartományában szeretnénk megkeresni a legnagyobb vagy a legkisebb értéket, akkor arra használjuk a MAX vagy a MIN függvényeket. A példatáblázatban arra használtuk a fenti függvényeket, hogy megkeressük az egyes színházak férőhely típusai közül a legnagyobb (26. ábra) és a legkisebb értékeket.

VLOOKUP, HLOOKUP függvények

A VLOOKUP és a HLOOKUP függvény általános alakja a következő:

VLOOKUP(keresési érték;tábla;oszlopszám;tartományban keres)

HLOOKUP(keresési érték;tábla;oszlopszám;tartományban keres)

A VLOOKUP függvény egy általunk (a keresési érték paraméterben) megadott értéket keres meg egy táblázat első oszlopában. Abban a sorban, ahol a megadott értéket megtalálta, megkeresi az oszlopszám paraméterben meghatározott tőle jobbra eső első, második, vagy valahányadik) cellát, és annak az értékét adja eredményül

Keresési érték: Az az érték, amit a függvénynek meg kell találni a tábla első oszlopában. Tartalmazhat számot, hivatkozást vagy szöveget.

Tábla. Az a tartomány, amelynek első oszlopában keresi a program a keresési értéket. Célszerű abszolút hivatkozást (lásd késöbb) megadni abban az esetben, ha a függvényt később más cellákba is másolni akarjuk.

Oszlopszám: A tábla tartomány azon oszlopának a száma, ahol a kiírandó adat van. Az első oszlop az 1-es.

Tartományban keres: A függvény olyan belső logikai értéke, amely a keresés típusát határozza meg. Ha ennek értékként 0-át adunk, akkor csak pontos egyezés esetén ad eredményt a függvény. Ebben az esetben nem szükséges, hogy a táblázatunk első oszlopa szerint növekvő sorrendbe rendezett legyen.

Amennyiben nem adjuk meg a keresés típusát (üresen hagyjuk a paramétert), vagy pedig Igaz (1) értéket adunk meg, akkor ha a keresett érték nem található, az annál kisebb, hozzá legközelebb eső számot találja meg. Például ha a táblánk első oszlopának adatai rendre 17, 25, 36, 52, 80, és ebben keressük a 30-as számot, akkor a 25-öst találja meg.

FONTOS! 1-es Tartományban keres paraméter érték megadásánál mindig, rendezzük sorba az első oszlop adatai szerint táblázatunkat, mielőtt a függvényt használnánk.

A HLOOKUP függvény a VLOOKUP testvére, ugyanúgy működik, csak a táblázatunk első sorának adatai között keres vízszintes irányban. A megtalált oszlopban az oszlop sorszám paraméterben meghatározott sorából fogja az eredményt venni.

TODAY() függvény

Ha egy tetszőleges cellába beírjuk =TODAY() , akkor abban a cellában a mai dátum jelenik meg. Használata azért előnyös, mert ha a későbbiek folyamán ezt a táblázatot használjuk, ebben a cellában mindig az aktuális napi dátum jelenik meg.

Például: írjuk be az A1-es cellába a születési dátumunkat. Írjunk az A3-es cellába olyan képletet, amely kiszámolja, hogy a mai napon hány naposak vagyunk!

A képlet összeállítása nagyon egyszerű! Beírjuk az A2-es cellába a TODAY() függvényt. Az A3-as cellában nem kell mást tennünk, mint a mai nap dátumából ki kell vonnunk a születési dátumunkat. A3=A2-A1 Ilyenkor azonban gyakran megakadunk, hiszen a probléma az, hogy az eredmény egy számérték, amit a program nem számként, hanem dátumként értelmez, és úgyis jeleníti meg. Ekkor nem kell mást tennünk, minthogy a Számforma beállításnál választanunk kell az Általános számformát, és ekkor az eredményünk számértékként, napban kifejezve jelenik meg.


Tömbfüggvények[szerkesztés]

A tömbfüggvények abban különböznek az egyszerű függvényektől, hogy a bemeneti értéküket nem egyetlen cellából, hanem egy több cellából álló összefüggő tartományból, azaz tömbből veszik. Egyes tömbképletek egyetlen értéket adnak eredményül, mások eredménye szintén egy (az eredeti méretével rendszerint megegyező méretű) tömb.

Tömbképletet akkor érdemes használni, ha egy számítást több értékkel kell elvégezni. Ez esetben ha a számítás módján változtatunk, akkor elég a tömbképletet egyszer módosítani, és a számítás az összes cellában frissülni fog.

Tömbképlet létrehozása egyszerű esetben: Készítsd el az adataidat egy cellatartományban. (Ez tartalmazhat egy vagy több összefüggő sort illetve oszlopot.) Jelölj ki egy ugyanakkora területet az eredmények számára. A Beszúrás menüből válaszd a Függvény menüpontot (Control+F2), válaszd ki a megfelelő függvényt. Ne felejtsd el a párbeszédpanelen bejelölni az Adattömb négyzetet. A számnál add meg az eredeti adattömböt. Az OK-ra kattintva létrejött a tömb függvény.

Hivatkozások[szerkesztés]

A hivatkozásoknak nagyon nagy szerepe van a táblázatkezelésben. Ahhoz, hogy a képleteket minél egyszerűbben használhassuk, meg kell ismernünk a hivatkozások különböző típusait. Ha megtanuljuk megfelelően alkalmazni ezeket, akkor a kitöltő-négyzet segítségével általában nagyon könnyen és helyes eredményt kapva tudjuk a képleteinket más cellákba másolni, örökíteni.

Relatív hivatkozás[szerkesztés]

Már az eddigiekben is foglalkoztunk hivatkozásokkal. Megtanultuk azt, hogy egy kijelölt sornak, oszlopnak, egy cellának vagy bármilyen tartománynak a leírását hogyan adhatjuk meg. Ezeknek a hivatkozásoknak az a tulajdonsága, hogy ha átmásolunk egy hivatkozást tartalmazó cellát egy másikba, akkor nem ugyanarra a cellára mutató hivatkozást kapunk a célcellában, hanem az elmozdulásnak megfelelően változnak a hivatkozás adatai is. A relatív hivatkozást a Calc nem a cella címével tárolja, hanem azt jegyzi meg, hogy a hivatkozott cella hány sor és hány oszlop távolságra van attól a cellától, amelyikbe a hivatkozást írtuk. A Calc megkeresi, hogy az új cellához képest melyik cella van ugyanolyan irányú és mértékű távolságra.

Megfigyelhető az, hogy relatív hivatkozással másolt képleteknél amennyiben egy hivatkozást balra vagy jobbra másoltunk, akkor az új képletben az oszlop betűjele fog nőni vagy csökkenni, míg ha lefelé vagy felfelé másoltunk, akkor a sor számjele fog változni. A növekedés vagy csökkenés mértéke attól függ, hogy hány cellával másoltuk újabb helyre a képletet.

Abszolút hivatkozás[szerkesztés]

Az abszolút hivatkozás annyit jelent, hogy egy hivatkozást tartalmazó képlet másolásánál a Calc nem követi az elmozdulás mértékét, hanem mindig az eredeti hivatkozás marad meg az új helyeken is a képletekben. A Calcban a relatív hivatkozás az alapértelmezett. Ha egy relatív hivatkozást abszolút hivatkozásúvá szeretnénk alakítani az oszlop és sorjelek elé $ jelet kell írnunk. Ha egy relatív hivatkozást szerkesztünk, a SHIFT+F4 billentyűkombinációval abszolút hivatkozássá alakíthatjuk.

Vegyes hivatkozás[szerkesztés]

Az abszolút és a relatív hivatkozások kombinációját nevezzük vegyes hivatkozásnak. A vegyes hivatkozás lehet vagy oszlopra relatív/sorra abszolút (A$8), - vagy fordítva - oszlopra abszolút/sorra relatív típusú ($A8). Másolás esetén a hivatkozás azon része, ami relatív az elmozdulás hatására változik, míg az abszolút hivatkozású rész nem változik.

Ha a kurzorunk egy képletben egy hivatkozáson áll, az F4 ??? Ez az F4 gyanús ??? funkcióbillentyű többszöri lenyomásával váltogathatunk a megjelenő hivatkozás típusok között.

Diagramok készítése[szerkesztés]

A diagramok nem mások, mint a táblázatunkban lévő adatok szemléletes, grafikus megjelenítése. Jól kiemelik a fontos adatainkat, és a számadatok böngészése helyett lehetőséget adnak arra, hogy a szemlélő azonnal észrevehesse az adatok között fennálló törvényszerűségeket, trendeket.

A Calc-ban diagramot a Beszúrás menü Diagram pontjában hozhatunk létre. Az első dolgunk az legyen, hogy kijelöljük a táblázatnak azt a részét, amelyből diagramot akarunk készíteni.

Az első ablakban határozható meg, hogy a táblázat mely részéből készüljön a diagram, hova kerüljön majd a kész diagram, illetve hogy az első sor vagy oszlop legyen a felirat.

OOo1 Calc Diagramm beszúrása Első lépés.png

A második ablakra a Tovább gomb megnyomásával juthatunk. Ebben az ablakban állítható be a diagram formája (típusa), a sorok és oszlopok sorrendje, valamint a tengelyek szöveges feliratozása is.

Ha kiválasztjuk a nekünk tetsző típust, a bal oldali minta ablakban azonnal látható is lesz, hogy milyen lesz a kész diagram.

OOo1 Calc Diagramm beszúrása Második lépés.png

A harmadik ablakban az altípust választhatjuk ki, valamint a rácsvonalakat kapcsolhatjuk be.

A harmadik lépésben címet adhatunk a diagramnak, be- illetve kikacsolhatjuk a jelmagyarázatot, az x és y tengelynek feliratot szerkeszthetünk.

Ha háromdimenziós grafikontípust választottunk, akkor a z tengelynek is adhatunk feliratot.

OOo1 Calc Diagramm beszúrása Harmadik lépés.png

Ezek után nincs más teendőnk, mint a létrehozás gombra kattintani, és az első lépésben megadott helyen létrejön a diagram.

OOo1 Calc Eredményül kapott diagramm.png

További függvények[szerkesztés]

A COUNT függvény az argumentumlistában szereplő számokat és számokat tartalmazó cellákat számlálja meg. A függvény egy tartomány vagy egy számtömbben lévő bejegyzések számának megállapítására használható.

Szintaxis

COUNT(érték1;érték2;...)

Érték1, érték2, ... Legfeljebb 30 argumentum, amely különböző adattípusokat tartalmazhat, illetve különböző adattípusokra hivatkozhat, de azok közül csak a számokat számlálja meg.

Symbol opinion vote.svg - ( A függvény csak a számokat számolja meg. A logikai értékeket, a dátumokat, a szövegként megadott számokat, az üres cellákat, a hibaértékeket és a számokká nem konvertálható szövegeket figyelmen kívül hagyja.

Ha egy argumentum tömb vagy hivatkozás, a tömbben, illetve a hivatkozásban csak a számokat veszi figyelembe a függvény, az üres cellákat, logikai értékeket, szövegeket vagy hibaértékeket figyelmen kívül hagyja. Ha a logikai értékeket, szövegeket vagy hibaértékeket is meg szeretnénk számolni, használjuk a COUNTA függvényt.

A COUNTA függvény az argumentumlistában szereplő nem üres cellákat és értékeket számlálja össze. A függvénnyel egy tartomány vagy egy tömb adatot tartalmazó celláinak száma kapható meg.)

Szintaxis

COUNTA(érték1;érték2;...) Érték1, érték2, ... Legfeljebb 30 argumentum, amely a megszámolni kívánt értékeket tartalmazza. A függvény minden adattípust értéknek tekint, még az üres szöveget ("") is, de nem veszi értéknek az üres cellákat. Ha az argumentum tömb vagy hivatkozás, akkor a függvény a tömbben, illetve a hivatkozásban lévő üres cellákat figyelmen kívül hagyja. Ha nem kell logikai értékeket, szöveget vagy hibaértéket számlálnunk, használjuk a COUNT függvényt.

COUNTIF: egy tartományban összeszámolja azokat a cellákat, amelyek eleget tesznek a megadott feltételnek.

Szintaxis

COUNTIF(tartomány;kritérium)

Tartomány. Az a tartomány, amelyben a cellákat szeretnénk megszámlálni.

Kritérium. Az összeszámolandó cellákat meghatározó, számként, kifejezésként vagy szövegként megadott feltétel. Például a feltétel megadható a következő formában: 32, "32", ">32", "alma".

COUNTBLANK: a megadott tartomány üres celláit számolja meg.

Szintaxis

COUNTBLANK(tartomány)

Tartomány. Az a tartomány, amelyben az üres cellákat meg kell számolni.

Symbol opinion vote.svg - (A függvény az üres szöveget ("") eredményező képleteket tartalmazó cellákat is figyelembe veszi, de a zérus értéket tartalmazókat nem. IF: más értéket ad vissza, ha a megadott feltétel kiértékelésének eredménye IGAZ, és másikat, ha HAMIS.

Az IF függvénnyel feltételes vizsgálatok hajthatók végre értékeken és képleteken.)

Szintaxis

IF(logikai_vizsgálat;érték_ha_igaz;érték_ha_hamis) Logikai_vizsgálat Tetszőleges érték vagy kifejezés, amely kiértékeléskor IGAZ vagy HAMIS eredményt ad. Például az A10=100 logikai kifejezés, amely kiértékeléskor IGAZ értéket ad, ha az A10 cella tartalma 100, minden más esetben az eredmény a HAMIS érték. Az argumentumban tetszőleges összehasonlító operátor használható.

Érték_ha_igaz. Ezt az értéket adja a függvény eredményül, ha a logikai_vizsgálat eredménye IGAZ. Ha például az argumentum értéke "Költségvetésen belül", és a logikai_vizsgálat eredménye IGAZ, akkor a HA függvény a "Költségvetésen belül" szöveget jeleníti meg. Ha a logikai_vizsgálat IGAZ és az érték_ha_igaz üresen hagyott, a visszatérési érték 0 (nulla) lesz. Az IGAZ szó megjelenítéséhez használjuk az IGAZ logikai értéket az argumentumban. Az érték_ha_igaz képlet is lehet.

Érték_ha_hamis. Ezt az értéket adja a függvény eredményül, ha a logikai_vizsgálat eredménye HAMIS. Ha például az argumentum értéke "Költségvetésen kívül", és a logikai_vizsgálat eredménye HAMIS, akkor a HA függvény a "Költségvetésen kívül" szöveget jeleníti meg. Ha a logikai_vizsgálat HAMIS és az érték_ha_hamis nincs megadva (azaz az érték_ha_igaz után nincs pontosvessző), a visszatérési érték a HAMIS logikai érték. Ha a logikai_vizsgálat HAMIS és az érték_ha_hamis üresen hagyott (azaz az érték_ha_igaz után pontosvessző és zárójel áll), a visszatérési érték 0 (nulla) lesz. Az érték_ha_hamis képlet is lehet.

Symbol opinion vote.svg - (Összetett vizsgálatok esetén legfeljebb hét IF függvényt ágyazhatunk egymásba érték_ha_igaz és érték_ha_hamis argumentum formájában. Lásd az alábbi példák közül az utolsót.

Amikor a HA függvény kiértékelte az érték_ha_igaz és az érték_ha_hamis argumentumot, akkor a kettő közül a megfelelő utasítás értékét kapjuk eredményül.

Amennyiben az IF függvény bármely argumentuma tömb, akkor a tömb összes elemét kiértékeli a függvény.)

Gyakorló feladatok[szerkesztés]

OOo1 Calc Első gyakorló feladat.png

OOo1 Calc Második gyakorló feladat.png

OOo1 Calc Harmadik gyakorló feladat.png

OOo1 Calc Negyedik gyakorló feladat.png

OOo1 Calc Ötödik gyakorló feladat.png

OOo1 Calc Hatodik gyakorló feladat.png