OpenOffice.org a gyakorlatban/Writer/Első fejezet

A Wikikönyvekből, a szabad elektronikus könyvtárból.
Ugrás a navigációhoz Ugrás a kereséshez

Az OpenOffice.org Writer használatának megkezdése[szerkesztés]

Az OpenOffice.org irodai programcsomag szövegszerkesztőjét Writer-nek nevezik. Indítása vagy a „Start” menü ► „Programok” ► „OpenOffice.org” ► „Szöveges dokumentum” pontjával lehetséges, vagy a Tálca jobb alsó sarkában lévő OpenOffice.org gyorsindítóra a jobb egérgombbal kattintva és a „Szöveges dokumentum” pontot választva. Az alábbi kép fogad bennünket a monitoron:

OOo1 Writer Üres dokumentum.png

A képernyő tetején látható közvetlenül a címsor alatt a „Menüsor”:

OOo1 Writer Menüsor.png

A menüsor alatt található a „Műveletek eszköztár”:

OOo1 Writer Műveletek eszköztár.png

A Műveletek eszköztár alatt helyezkedik el az „Objektum eszköztár”. Az „Objektum eszköztár”-nak többféle megjelenési formája van, attól függően, hogy az aktuálisan szerkesztett objektum szöveg – „Szövegobjektum eszköztár”, kép – „Képobjektum eszköztár”, keret – „Keretobjektum eszköztár”, táblázat – „Táblázatobjektum eszköztár” vagy éppen egy OLE objektum – „Objektum eszköztár”.

A „Szövegobjektum eszköztár”

A képernyő bal oldalán (állva) helyezkedik el a „Fő eszköztár”.

Az ablak legalsó részén helyezkedik el a „Státuszsor”, ahol a program kijelzi az aktuális dokumentum oldalszámát, a nagyítás mértékét (a képernyőn), a beírómódot és az elválasztás mikéntjét.

OOo1 Writer Státuszsor bal oldala.png OOo1 Writer Státuszsor jobb oldala.png

A képernyő legnagyobb részét a szerkesztőablak, azaz „papírlap” teszi ki. Ez az a rész, ahová a szöveget írhatjuk.

A következőkben a dokumentumkészítés menetét tekintjük át, nem a menüpontok sorrendjében, hanem a használat gyakorisága szerint.

Fájlformátumok[szerkesztés]

Az OpenOffice.org alapértelmezésben bármilyen – a program által ismert – formátumot megnyit, de a dokumentum mentéshez a saját formátumát ajánlja fel elsőként. Természetesen lehetőség van, a dokumentum, egyéb fájlformátumban történő mentésére is. Mentéskor mindig legyünk tekintettel a dokumentum tervezett további felhasználására. Nem mentsünk dokumentumot nehezen szerkeszthető formátumba (például: *.PDF), ha azt a továbbiakban is szerkeszteni szeretnénk, vagy mástól várjuk el a dokumentum szerkesztését. Legyünk tekintettel a fogadó fél által használt programok fájlformátumaira és abban küldjük el a dokumentumot.

OpenOffice.org 2.x dokumentum formátumok és a hozzájuk tartozó fájlkiterjesztések[szerkesztés]

Az OpenOffice.org saját formátumai a különféle alkalmazásaihoz – a megkülönböztethetőség érdekében – különféle fájlkiterjesztéseket alkalmaz. Ezek a fájlformátumok XML alapú fájlformátumok, amelyeket az OASIS, azaz a Organization for the Advancement of Structured Information Standards elnevezésű szervezet által szabványosított, elterjedt fájlformátum. Az OpenOffice.org 2.x verziója ezeket, a szabványos fájformátumokat használja. Ezeket a fájlformátumokat összefoglaló néven OpenDocument fájlformátumnak nevezzük. Megjegyezendő, hogy a kereskedelmi termékként árult StarOffice 8.0, amely az OpenOffice.org program hivatalos kereskedelmi változata, szintén ezt a fájlformátumot alkalmazza. Célszerű ebben a fájlformátumban tárolni a dokumentumainkat és ajánlatos ebben a formátumban továbbadni a dokumentumunkat, ha fogadó fél rendelkezik az OpenOffice.org 2.x verziójával vagy a StarOffice 8.0 verziójával.

Dokumentum formátum Fájlkiterjesztés
OpenDocument-szöveg *.odt
OpenDocument-szövegsablon *.ott
OpenDocument-fődokumentum *.odm
HTML-dokumentum *.html
HTML-dokumentumsablon *.oth
OpenDocument-munkafüzet *.ods
OpenDocument-munkafüzetsablon *.ots
OpenDocument-rajz *.odg
OpenDocument-rajzsablon *.otg
OpenDocument-bemutató *.odp
OpenDocument-bemutatósablon *.otp
OpenDocument-képlet *.odf
OpenDocument-adatbázis *.odb

OpenOffice.org 1.x dokumentum formátumok és a hozzá tartozó fájlkiterjesztések[szerkesztés]

A kompatibilitás megörzése érdekéen az OpenOffice.org tökéletesen kezeli az 1.x verzió fájlformátumát is. Ez a fájlformátum, bár nyílt fájlformátum csak az OpenOffice.org 1.x sorozat sajátja maradt. Az OpenOffice.org 2.0 OpenDocument fájlformátuma sok közös vonást mutat az 1.x verzió fájlformátumával, aminek előnye a két dormátum közötti egyszerű átjárás, átalakíthatóság. Célszerű ebben a formátumban továbbadni a dokumentumunkat, ha fogadó fél rendelkezik az OpenOffice.org 1.x verziójával.

Dokumentum formátum Fájlkiterjesztés
OpenOffice.org 1.0-szövegesdokumentum *.sxw
OpenOffice.org 1.0-szövegesdokumentumsablon *.stw
OpenOffice.org 1.0-fődokumentum *.sxg
OpenOffice.org 1.0-munkafüzet *.sxc
OpenOffice.org 1.0-munkafüzetsablon *.stc
OpenOffice.org 1.0-bemutató *.sxi
OpenOffice.org 1.0-bemutatósablon *.sti
OpenOffice.org 1.0-rajz *.sxd
OpenOffice.org 1.0-rajzsablon *.std
OpenOffice.org 1.0-képlet *.sxm

Fájl menü[szerkesztés]

A Fájl menü

A Fájl” menü ► „Új” pontjában lehet új, üres dokumentumot nyitni, de nemcsak „Szöveges dokumentum”-ot (ez a Wordnek megfelelő Writer szövegszerkesztő formátuma), hanem „Munkafüzet”-et (ez az Excelnek megfelelő Calc számolótáblája), „Bemutató”-t (ez a Powerpointnak megfelelő Impress prezentációkészítő formátuma), „Rajz”-ot (ez a beépített Draw rajzoló formátuma) és egyéb formátumokat is, például „HTML-dokumentum”-ot, amit közvetlenül a böngészőben vagy az interneten is megtekinthetünk. A „Megnyitás...” menüpontban már létező dokumentumot hívhatunk be a szövegszerkesztőbe és módosíthatjuk, nyomtathatjuk. Ha ezt a pontot választjuk egy megnyitóablakban találjuk magunkat, ahol kiválaszthatjuk a keresett fájlt tartalmazó könyvtár helyét és kiválaszthatjuk a megnyitandó fájlt.

Az OpenOffice.org nemcsak a saját formátumát tudja megnyitni, hanem elboldogul más szövegszerkesztők által készített dokumentumformátumokkal is, így például a Microsoft Office család formátumaival is.

Fájlok megnyitása[szerkesztés]

A fájl menü Megnyitás ablaka

A „Hely” legördülő menüben lehet megkeresni azt a meghajtót, ahol a kívánt dokumentum található. Ez általában a „C:\” meghajtó „Dokumentumok” mappája szokott lenni, Windows 2000 és Windows XP esetén a „C:\” meghajtó gyökerében lévő „Documents and Settings” nevű mappában lévő „felhasználónév” nevű könyvtárban lévő „Dokumentumok” mappa. A felhasználónév az a név, ahogyan bejelentkeztek a gépre, hálózatra. A „Hely” legördülő menütől jobbra található a „Vissza” gomb, ezzel az előző helyre ugorhatunk vissza, az „Egy szinttel feljebb” gomb, ezzel a könyvtárszerkezetben egy szinttel léphetünk feljebb, az „Új mappa létrehozása” gomb, ezzel egy mappát hozhatunk létre az adott helyen és a „Nézetek” gomb, ahol az ablakban megjelenő mappa- és fájlnevek megjelenését szabályozhatjuk.

„Nézetek” gomb a lehetséges opciókkal

„Miniatűrök” esetében kis képecskeként mutatja a dokumentumokat, a képeket pedig lekicsinyítve. „Mozaik” esetén kisebb ikonként több oszlopban, „Ikonok” esetén egymás mellett és alatt még kisebb ikonokként, „Lista” esetében bal oldalon egy kicsi ikon, mellette a fájl neve, „Részletek” esetén pedig mellette a méret, a típusa és az utolsó módosítás ideje látható.

A „Csak olvasható módban” való megnyitás esetén nem lehet módosítani a fájlt.

Az ablak alján lehet kiválasztani a „Fájltípus” mezőben a kívánt fájlformátumot, alaphelyzetben minden megnyitható fájlt mutatni fog a „Megnyitás” ablakban.

A jelszóval mentett dokumentumok megnyitásához meg kell adni a jelszót. Ilyenkor az OpenOffice.org a jelszót az alábbi párbeszédablakban várja:

OOo1 Writer Jelszóval védett dokumentum megnyitása.png

A dokumentumok jelszavas mentéséről lentebb a Mentés és Mentés másként... fejezetben olvashat részletesen.

Tündér[szerkesztés]

A Fájl menü Tündérek almenüje

A „Tündér” segítségével a leggyakrabban használt levélformátumok előre legyártott szerkezetét – sablonokat – hívhatjuk be, amit kitöltve a saját szövegünkkel lényegesen gyorsabban elkészíthetünk egy levelet vagy bármilyen dokumentumot. Ha ráhúzzuk az egeret a menüpontra akkor oldalt megjelenik egy almenü, amit a „Tündér” menüpont melletti kis fekete háromszög is jelez, és a kész sablonokból választhatunk. Ezután a tündér néhány előre felkínált beállításból történő választásra kér meg és már készen is van az előre formázott dokumentum, csak a saját szövegünket kell begépelni a megfelelő helyre. A tündérek segítségével gyorsabban hozhatunk létre üzleti vagy magánleveleket (Levéltündér), faxokat (Fax tündér), készíthetünk napirendet (Napirend tündér), bemutatókat (Bemutató tündér), tetszőleges dokumentumból Internetre feltölthető weboldalakat (Web tündér). A további tündérekkel konvertálhatunk dokumentumokat régebbi StarOffice, OpenOffice.org változatokból vagy Microsoft Office fájformátumokból (Dokumentumkonvertáló tündér), pénznemeket válthatunk át (Euróváltó tündér), szótárfájlokat tölthetünk le helyesírás-ellenőrzéshez, szinonima kereséshez, elválasztáshoz (DicOOo tündér), betűkészleteket telepíthetünk (Betűkészletek telepítése a webről tündér).

Bezárás[szerkesztés]

Ebben a menüpontban zárhatjuk be az aktuális dokumentumot. Amennyiben még nem volt mentve vagy módosítottunk valamit, amit még nem mentettünk el, akkor a program rákérdez, hogy menteni akarjuk-e előtte.

Menti a módosításokat?

Az OpenOffice.org-ban több dokumentum is nyitva lehet, ezek között az „Ablak menü” alján tudunk választani, vagy a Tálcára kattintva.

Mentés és Mentés másként...[szerkesztés]

Ezekben a menüpontokban lehet a dokumentumunkat rögzíteni valamilyen háttértárolón, fájl formájában. Ha még nem volt elmentve a dokumentum, akkor az OpenOffice.org „Névtelen”-ként hivatkozik rá.

Az első mentéskor mindig a „Mentés másként” ablak jön elő, bármelyik menüpontra is kattintunk, ahol is meg kell adnunk egy nevet a fájlnak.

Itt határozhatjuk meg azt is, hogy hol jöjjön létre a fájl és milyen legyen a formátuma. Alapértelmezés az OOo 1-ben az sxw, vagyis az OpenOffice.org saját formátuma. Ha már van neve a fájlnak, akkor csak egy kék csík szalad végig a státuszsoron, és megtörténik a fájl rögzítése.

OOo1 Writer Mentés másként.png

A kiterjesztést nem kell beírnunk, ezt az OpenOffice.org automatikusan megteszi helyettünk, ha be van kapcsolva az „Automatikus fájlkiterjesztés” jelölőnégyzet.

A mentéskor figyelni kell arra, hogy olyan helyre mentsük el a dokumentumot:

  • ahol van elegendő hely,
  • ahova van írási jogosultságunk.

Ha védeni akarjuk a dokumentumunkat, akkor lehet jelszóval is menteni, ilyenkor egy jelszóbeíró panel jelenik meg a „Mentés” gombra kattintva.

Adja meg a jelszót - ablak

Itt kétszer kell beírni a jelszót. A jelszónak legalább öt karakternek kell lennie, addig nem lesz aktív az „OK” gomb. Ha valaki ezek után meg akarja nyitni ezt a dokumentumot, akkor az OpenOffice.org jelszót fog tőle kérni, amíg nem adják meg, nem nyitja meg a dokumentumot.

Összes mentése[szerkesztés]

Az Összes mentése menüpontot választva az összes, megnyitott dokumentumban lévő változtatásaink elmentődnek. A mentés menete megegyezik az előző pontban ismertetett Mentés és Mentés másként... parancsokkal úgy, hogy az minden egyes dokumentumon végrehajtódik.

Újratöltés[szerkesztés]

Ezt a menüpontot kiválasztva a legutolsó mentéskori állapot változat töltődik be. Amennyiben a dokumentumon már módosítottunk a következő kérdés jelenik meg:

Elveti a változásokat?

Amennyiben a „Nem” gombra kattintunk, nem történik meg az újratöltés. Mielött az „Igen” gombra kattintunk, gondoljuk át, hogy a változtatások elvesztése nem okoz-e valóban problémát, ha nem, kattintsunk az „Igen” gombra, amely hatására betöltődik az utoljára mentett állapot.

Exportálás..., Exportálás PDF-be...[szerkesztés]

Az OpenOffice.org képes a dokumentumot .xhtml és .pdf formátumba exportálni. Ezekből számunkra a *.PDF a lényeges, mert ha el kell küldeni a dokumentumunkat valahova, és fontos, hogy a dokumentum pontosan úgy nézzen ki, mint ahogy nálunk, akkor ezt ebben a formátumban kell megtenni. Főleg pályázatok és egyéb adatlapok esetében ajánlatos ezt a formátumot használni. A .pdf állományok közvetlenül nem szerkeszthetők, tehát véletlenül a címzett nem is tud beleturkálni. Ha fontos, hogy a címzett módosíthasson az állományban, akkor a „Mentés másként” menüponttal Rich Text Format formátumban (*.RTF) kell elmentenünk és úgy már küldhetjük.

Az „Exportálás PDF-be...” menüponttal közvetlenül pdf fájlba exportálhatjuk a dokumentumot.

Küldés[szerkesztés]

A küldés menüpontban többféle elküldési mód közül lehet választani, a legfontosabb az első kettő, a „Dokumentum e-mailként...”, és a „Dokumentum PDF-mellékletként...”.

A „Dokumentum e-mailként...” menüpont választása esetén az aktuális dokumentumot csatolja az alapértelmezett levelezőprogramban egy új levélhez mellékletként. Például Mozilla vagy Netscape levelező használata esetén elindul a Levelező, megnyílik egy új levél, amihez már csatolva van a fájl.

A „Dokumentum PDF-mellékletként...” való küldése esetén a levél .pdf formátumban kerül csatolásra. NAGYON AJÁNLOTT a dokumentumok ilyen formátumban való küldése, mert ezt az Acrobat Reader programmal meg lehet tekinteni és nem fertőződhetnek meg vírussal. A Reader program ma szinte minden számítógépen telepítve van, használata ingyenes.

Nyomtatási kép[szerkesztés]

Ebben a menüpontban megtekinthetjük, hogy dokumentumunk hogyan fog kinézni papíron, nyomtatás után.

OOo1 Writer Nyomtatási kép.png

Az ábrán látható, hogy ilyenkor megjelenik egy új eszköztár is a képernyőn, a „Műveletek eszköztár” alatt.

OOo1 Writer Nyomtatási kép Műveletek eszköztár.png

A gombok jelentése balról jobbra haladva:

  • Előző oldal: az előző oldalra lapoz,
  • Következő oldal: a következő oldalra lapoz,
  • Dokumentum elejére: a dokumentum legelejére ugrik,
  • Dokumentum végére: a dokumentum legvégére ugrik,
  • Nyomtatási kép kétoldalas: egyszerre két egymás melletti oldalt mutat a képernyőn,
  • Nyomtatási kép többoldalas: egyszerre több egymás melletti oldalt mutat a képernyőn.
  • A nagyítókkal nagyíthatjuk, kicsinyíthetjük a képernyőn a megjelenített oldalt, illetve a százalékos mezőben tetszőleges nagyítást vagy kicsinyítést beállíthatunk.
  • Teljes képernyő esetén eltűnik az eszköztár és a dokumentum a lehető legnagyobb méretben jelenik meg. A „Nyomtatás” ikonnal nyomtathatjuk az egész dokumentumot, ha nem az egészre van szükségünk, akkor ez a „Nyomtatási beállítások” pontban tetszésünk szerint megváltoztathatjuk. A nyomtatási kép bezárása gombra kattintva visszatérhetünk a dokumentum szerkesztéséhez.

Nyomtatás[szerkesztés]

A Nyomtatás beállítására szolgáló ablak

A „Név” legördülő menüben választhatjuk ki, hogy a gépünkre telepített nyomtatók közül melyiken akarjuk kinyomtatni a dokumentumot vagy annak részeit. A „Tulajdonság” gombra kattintva a kiválasztott nyomtató tulajdonságait lehet beállítani, alapesetben erre nagyon ritkán van szükség.

A nyomtatás fájlba menüpontot választva a program az adatokat nem a nyomtatónak küldi, hanem kér tőlünk egy fájlnevet és abba írja.

A „Nyomtatási tartomány” részben állíthatjuk be, hogy a dokumentum összes oldalát akarjuk nyomtatni, csak meghatározott részét (Például: 4-8 a negyedik oldaltól a nyolcadikig nyomtat), vagy esetlegesen ha kijelöltünk egy részt, akkor csak a kijelölt rész nyomtatódjon ki. Mellette állítható be, hogy hány példányban akarjuk nyomtatni a dokumentumot, illetve többoldalas dokumentum esetében kérünk-e leválogatást a programtól. Ilyenkor a program garnitúránként nyomtatja a dokumentumot a kívánt példányszámban.

A „Beállítások...” gombra kattintva egy újabb ablak bukkan fel, amelyen meghatározhatjuk a „Nyomtatandó elemek” típusait, megadhatjuk,hogy az „Oldalak” hogyan legyenek nyomtatva, beállíthatjuk az oldalakhoz fűzött „Jegyzetek” nyomtatási módját. Az „Egyéb” pontban lehetőség van minden oldalt külön nyomtatási feladatban nyomtatni, amennyiben bejelöljük az „Önálló nyomtatási feladatok” lehetőséget. Továbbá a „Papírtálca-választás a nyomtató beállításai szerint” opcióval a nyomtató beállításainak megfelelően kerül kiválasztásra a papírtálca.

OOo1 Writer Nyomtatási beállítások.png

Ha az adott dokumentumot Faxon keresztül kívánjuk elküldeni akkor „Fax” legördülő menüből kiválaszthatjuk a rendszerre telepített fax eszközök egyikét.

A Beállítások gombra kattintva részletesen szabályozhatók a nyomtatási paraméterek.

Nyomtatási beállítások[szerkesztés]

OOo1 Writer Nyomtató beállítása.png

Itt külön is beállíthatjuk a nyomtatónk paramétereit. A „Nyomtató beállítása” ablakban a „Név” mezőben megadott nyomtatót a „Tulajdonságok...” gomb megnyomásával állíthatjuk be. Ekkor a nyomtató-meghajtóprogram, valamint az operációs rendszer által felkínált nyomtatóbeállítási ablakokhoz jutunk. Ezekről a beállításokról részletesen, a nyomtató dokumentációjában, valamint az operációs rendszer súgójában, vagy a mellékelt dokumentációban olvashat.

Kilépés[szerkesztés]

Ebben a menüpontban léphetünk ki az OpenOffice.org programból. Ha van nem lementett dokumentumunk, akkor a program rá fog kérdezni, hogy menteni akarjuk-e, tehát véletlenül nem tudunk mentés nélkül kilépni.

[[Kategória:OpenOffice.org a gyakorlatban